Прошивка TP-Link TL-MR3020 OpenWrt

1


TP-Link TL-MR3020 OpenWrt



Подробное описание установки и настройки


Во избежание трудностей, чётко следуйте инструкции.



Шаг первый — прошивка

Скачиваем прошивку на свой компьютер.

Файл называется «mr3020.bin», подходит ко всем версиям.



Так же пользователям Win, необходимо скачать программу Putty.



Подключаем роутер к компьютеру LAN-кабелем и включаем в розетку.

mr3020 LAN

В адресной строке браузера вводим 192.168.0.254 (это адрес по-умолчанию, написан на корпусе), вводим логин/пароль admin/admin, попадаем в web-интерфейс и переходим в System Tools ->Firmware Upgrade

Firmware Upgrade

Выбираем скаченый файл (mr3020.bin) и нажимаем кнопку Upgrade.



Ждём 5 минутНе трогайте и не отключайте роутер!

После этого роутер перезагрузится и адресом по умолчанию будет 192.168.1.1


Прошивка установлена.




Если уже стоит какая-то OpenWrt
Заходим на роутер и вводим следующие команды…

Переходим в папку /tmp:

cd /tmp



Скачиваем прошивку:

wget http://stdforum.ru/file/mr3020.bin





Прошиваем:

mtd -r write mr3020.bin firmware


Ничего не трогаем и ждём появления сообщения Rebooting ...



После этого ждём ещё минуту...


Прошивка установлена.





Шаг второй — установка пароля и подключение по SSH


По умолчанию в OpenWrt отключён защищённый протокол SSH и включён открытый протокол Telnet, это сделано из-за того, что не установлен пароль Администратора (root). Чтобы это изменить надо установить пароль.



Для пользователей Win

Пользователи Linux и Mac могут перейти ниже.


Запускаем ранее скачаную программу Putty:

Putty

Вводим адрес (192.168.1.1), выбираем протокол Telnet и нажимаем кнопку Open.

Появится консоль с приглашением ввода команд. Теперь мы «сидим на роутере».



1. Устанавливаем пароль администратора (root), для этого вводим команду passwd:

passwd



Нажимаем Enter.


Будет предложено ввести новый пароль для root, придумываем и записываем на бумажку!


Вводим и нажимаем Enter. Внимание! Символы отображаться не будут!

Bad password:
Если Вы введёте слишком простой пароль, то роутер предупредит об этом:



Если надёжность пароля не критична, то просто продолжайте, если критична, то нажмите два раза Enter, вернитесь к пункту 1 и придумайте пароль посложнее.

2. Роутер попросит повторить пароль:


Вводим и нажимаем Enter. Внимание! Символы отображаться не будут!


Если всё прошло удачно, роутер ответит:




Перегрузите роутер командой reboot

reboot


После этих манипуляций отключится протокол Telnet и заработает SSH.



Закрываем Putty и запускаем заново:



Вводим адрес (192.168.1.1), выбираем протокол SSH и нажимаем кнопку Open.

При первом соединении появится окно подтверждения соединения с незнакомым хостом.



Просто ответе Да.


Появится приглашение ввести логин:


Введите root и нажмите Enter.

Появится приглашение ввести пароль:


Введите пароль и нажмите Enter. Внимание! Символы отображаться не будут!

Получится вот так:



Всё, пароль установлен и ssh работает.




Для Linux и Mac


Открываем Терминал и пишем:

telnet 192.168.1.1


1. Вводим команду passwd:

passwd

Будет предложено ввести новый пароль для root, придумываем и записываем на бумажку!

Changing password for root
New password:

Вводим и нажимаем Enter. Внимание! Символы отображаться не будут!

Bad password:
Если Вы ввёдёте слишком простой пароль, то роутер предупредит об этом:

Bad password: too weak

Если надёжность пароля не критична, то просто продолжайте, если нет, то нажмите два раза Enter, венитесь к пункту 1 и придумайте пароль посложнее.

2. Роутер попросит повторить пароль:

Retype password:

Вводим и нажимаем Enter. Внимание! Символы отображаться не будут!

Если всё прошло удачно, роутер ответит:

Password for root changed by root



Перегрузите роутер командой reboot

reboot


После этих манипуляций отключится протокол Telnet и заработает SSH.

Закройте Терминал и откройте новый.

Введите:

ssh root@192.168.1.1

На вопрос «согласны ли Вы соединица с неизвестным хостом», напишите «yes» и нажмите Enter.

Введите пароль и нажмите Enter.

Всё, пароль установлен и ssh работает.




Шаг третий — настройка сети


Если MR3020 будет подключаться к другому (основному) роутеру, который подключён к интернету, тогда предполагается что он имеет адрес 192.168.1.1 и раздаёт адреса в диапазоне 192.168.1.2 — 254.
Если у Вас другая подсеть, то делайте всё что написано ниже, с учётом Вашего адресного пространства.



Действия одинаковы для всех операционных систем (Win, Linux, Mac).


Нужно отредактировать файл /etc/config/network

Заходим на роутер по ssh. (см. выше)

Вводим команду:

vi /etc/config/network




Текстовый редактор vi довольно-таки своеобразный инструмент.

Редактируем файл в соответствии с примером, для этого нажимаем символ "i" и вносим изменения:

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.39'
        option dns '8.8.8.8'
        option gateway '192.168.1.1'

Нажимаем Esc.
Вводим последовательно символы :wq (: w-сохранить q-выйти)
Нажимаем Enter.
Файл отредактирован.

То же самое проделаем с файлом /etc/config/wireless

Вводим команду:

vi /etc/config/wireless




Вносим изменения "i"

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option macaddr '64:66:b3:94:0a:da' # оставьте свой
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '27'
        option country 'US'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt' #название точки
        option encryption 'psk2'
        option key '1234qwer' #пароль (не меньше 8-ми символов)

Esc > :wq > Enter


Перегружаемся:

reboot



Если сеть строится через другой роутер, тогда выключаем MR3020 и переподключаем его и компьютер к основному роутеру.



Подключаемся вновь по ssh и вводим команду:

ping ya.ru




Если ping есть, то интернет настроен, нажмите Ctrl + z для выхода.

Если нет, то проверяем настройки файла /etc/config/network





Теперь надо поменять адрес репозитория в файле /etc/opkg.conf

vi /etc/opkg.conf


Редактируем в соответствии с примером:

src/gz attitude_adjustment http://stdforum.ru/packages/mr3020/packages/
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay

Первую строчку удалям и вместо неё вписываем указанную.
подсказка vi
Нажимаем символ "i".
Вносим изменения.
Нажимаем Esc.
Вводим последовательно символы :wq (: w-сохранить q-выйти)
Нажимаем Enter.
Файл отредактирован.


Вводим команду для обновления репозитория:

opkg update


Ответ должен быть такой:

Downloading http://stdforum.ru/packages/mr3020/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/...

Если вернётся ошибка, то проверьте файл /etc/opkg.conf




Шаг четвёртый — перенос системы на флешку


Утановим необходимые пакеты:

opkg update

opkg install kmod-usb-core kmod-usb-storage kmod-fs-ext4 kmod-scsi-core block-mount e2fsprogs fdisk kmod-usb-uhci kmod-usb-ohci


После установки вводим по очереди две команды:

insmod uhci

insmod usb-ohci



Вставляем флешку.


Создадим на флешке раздел.

Вводим команду:

fdisk -l

Флешка скорее всего определится как sda
Disk /dev/sda: 4009 MB, 4009754624 bytes
...


Вводим команду:

fdisk /dev/sda





Удаляем все разделы на флешке.
Жмём d и Enter пока не появится:

No partition is defined yet!






Создаем новый раздел.
Жмём n и Enter





Указываем его как первичный.
Жмём p и Enter





Жмём Enter





Жмём Enter





Жмём Enter





Готово





Сохраняем изменения:
Жмём w и Enter


Всё окей...




Раздел создан и его надо отформатировать: Потребуется некоторое время.

mkfs.ext4 /dev/sda1


Готово.



Содаём папку /mnt/usb, монтируем туда флешку и переносим систему:

mkdir -p /mnt/usb

mount -t ext4 /dev/sda1 /mnt/usb -o rw,sync

tar -C /overlay -cvf - . | tar -C /mnt/usb -xvf -




Теперь нужно отредактировать файл /etc/config/fstab

vi /etc/config/fstab


Секция mount

config 'mount'
option target /overlay
option device /dev/sda1
option fstype ext4
option options rw,sync
option enabled 1
option enabled_fsck 0

подсказка vi
Нажимаем символ "i".
Вносим изменения.
Нажимаем Esc.
Вводим последовательно символы :wq (: w-сохранить q-выйти)
Нажимаем Enter.
Файл отредактирован.

Сохраняем изменения и перегружаем роутер.

reboot




Заходим и проверяем:

df -h

В ответ должно быть что-то типа:

/dev/sda1 3.7G 65.8M 3.6G 2% /overlay
overlayfs:/overlay 3.7G 65.8M 3.6G 2% /

Ну вот, теперь места у нас полно, можно ставить что угодно.




Установим кодировки и Midnight Commander:

opkg update

opkg install kmod-nls-cp1251 kmod-nls-koi8r kmod-nls-utf8 kmod-nls-cp866 kmod-nls-cp437 

opkg install mc





Web-интерфейс LuCI:

opkg install luci luci-i18n-russian luci-proto-3g luci-proto-ppp ppp-mod-pptp ppp-mod-pppoa


Добавляем Luci в автозагрузку и стартуем:
/etc/init.d/uhttpd enable

/etc/init.d/uhttpd start


192.168.1.39





На этом всё

Здесь описана установка сервера Lighttpd и PHP.

Обсудить на форуме...


  • +1
  • 31281

Комментарии (75)

0
Здравствуйте! У меня выходит ошибка mount: mounting /dev/sda1 on /mnt/usb failed: Invalid argument
В чем проблема ?? Помогите пожалуйста!
0
Покажите вывод команды:
fdisk -l


и
ls /mnt
0
fdisk -l
Disk /dev/sda: 997 MB, 997195776 bytes
8 heads, 3 sectors/track, 81152 cylinders, total 1947648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x7482bfc8

Device Boot Start End Blocks Id System
/dev/sda1 2048 1947647 972800 83 Linux

ls /mnt
usb
+1
Попробуйте повторить четвёртый шаг заново. Цифр никаких вводить ненужно.
0
Два раза попробовал не получается помогите пожалуйста
0
Странно, может флешка не рабочая?
Что говорит эта команда?
mkfs.ext4 /dev/sda1
0
Флешка рабочая, подключал также и другую флешку но эффект тот же
mount: mounting /dev/sda on /mnt/usb failed: Invalid argument

Пару раз восстанавливал OpenWrt не помогает
root@OpenWrt:~# mkfs.ext4 /dev/sda1
mke2fs 1.42.4 (12-June-2012)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
128000 inodes, 511744 blocks
25587 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=524288000
16 block groups
32768 blocks per group, 32768 fragments per group
8000 inodes per group
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912

Allocating group tables: done
Writing inode tables: done
Creating journal (8192 blocks): done
Writing superblocks and filesystem accounting information: done

0
Как даёте команду mount?
0
mount -t ext4 /dev/sda1 /mnt/usb -o rw,sync
0
Что говорит это?
blkid /dev/sda1
0
или так
blkid
0
И что в fstab
vi /etc/config/fstab
0
root@OpenWrt:~# blkid
/dev/mtdblock2: TYPE="squashfs"
/dev/sda1: UUID="dc05cc6e-a800-4931-91a3-80a1ef3df709" TYPE="ext4"


config mount
        option target   /home
        option device   /dev/sda1
        option fstype   ext4
        option options  rw,sync
        option enabled  0
        option enabled_fsck 0
0
root@OpenWrt:~# blkid /dev/sda1
/dev/sda1: UUID="dc05cc6e-a800-4931-91a3-80a1ef3df709" TYPE="ext4"
0
lsmod

?
0
root@OpenWrt:~# lsmod
Module                  Size  Used by    Tainted: G
uhci_hcd               18208  0
ext4                  243518  0
jbd2                   40917  1 ext4
mbcache                 3949  1 ext4
crc16                   1015  1 ext4
usb_storage            34472  0
sd_mod                 22320  0
scsi_mod               75784  2 usb_storage,sd_mod
ath79_wdt               2320  1
ohci_hcd               16240  0
ledtrig_usbdev          2112  0
ledtrig_netdev          3264  0
nf_nat_irc               864  0
nf_conntrack_irc        2544  1 nf_nat_irc
nf_nat_ftp              1056  0
nf_conntrack_ftp        4496  1 nf_nat_ftp
ipt_MASQUERADE          1056  1
iptable_nat             2693  1
nf_nat                 10916  4 nf_nat_irc,nf_nat_ftp,ipt_MASQUERADE,iptable_nat
pppoe                   7568  0
xt_conntrack            2128  3
xt_CT                   1296  0
xt_NOTRACK               528  0
iptable_raw              640  1
xt_state                 688  0
nf_conntrack_ipv4       4500  6 iptable_nat,nf_nat
nf_defrag_ipv4           774  1 nf_conntrack_ipv4
nf_conntrack           40999 12 nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_conntrack_ftp,ipt_MASQUERADE,iptable_nat,nf_nat,xt_conntrack,xt_CT,xt_NOTRACK,xt_state,nf_conntrack_ipv4
ehci_hcd               33008  0
pppox                   1370  1 pppoe
ipt_REJECT              1888  2
xt_TCPMSS               2640  0
ipt_LOG                 6240  0
xt_comment               480  0
xt_multiport            1184  0
xt_mac                   608  0
xt_limit                1024  1
iptable_mangle           912  1
iptable_filter           672  1
ip_tables               9085  4 iptable_nat,iptable_raw,iptable_mangle,iptable_filter
xt_tcpudp               1712  3
x_tables               10949 18 ipt_MASQUERADE,iptable_nat,xt_conntrack,xt_CT,xt_NOTRACK,iptable_raw,xt_state,ipt_REJECT,xt_TCPMSS,ipt_LOG,xt_comment,xt_multiport,xt_mac,xt_limit,iptable_mangle,iptable_filter,ip_tables,xt_tcpudp
ppp_async               6032  0
ppp_generic            19314  3 pppoe,pppox,ppp_async
slhc                    4587  1 ppp_generic
ath9k                  88227  0
ath9k_common            1513  1 ath9k
ath9k_hw              322271  2 ath9k,ath9k_common
ath                    14873  3 ath9k,ath9k_common,ath9k_hw
mac80211              266831  1 ath9k
usbcore               104514  6 uhci_hcd,usb_storage,ohci_hcd,ledtrig_usbdev,ehci_hcd
usb_common               562  1 usbcore
nls_base                4958  1 usbcore
crc_ccitt               1019  1 ppp_async
cfg80211              162651  3 ath9k,ath,mac80211
compat                  6271  5 ath9k,ath9k_common,ath9k_hw,mac80211,cfg80211
arc4                     848  2
aes_generic            29961  3
crypto_algapi          10668  2 arc4,aes_generic
ledtrig_timer           1152  0
ledtrig_default_on       496  0
leds_gpio               1632  0
gpio_button_hotplug     3264  0
0
Хм, попробуйте загрузить роутер без флешки, потом её вставить и проделайте четвёртый шаг.
0
Хотя в fstab монтирование отключено. Непонятно…
Попробуйте на большом компьютере отформатировать флешку в ext4.
0
Все равно не работает, может прошивку заново залить или уже конец роутеру
0
С роутером всё нормально.

Выньте флешку, перегрузите роутер, выполните команду:
mtd -r erase rootfs_data

Это вернёт его в первоначальное состояние.

Начните с самого начала:
telnet 192.168.1.1

И т.д…
0
Да Я так уже 10-ый раз делаю, все равно одно и тоже Invalid ardument что
это значит вообще ?(
0
Система считает что в команде не хватает аргументов, а это, косвенно, говорит о том, что на флешке неправильно создана файловая система.

Может вы что то не так делаете fdisk_ом.

Вы можете на большом компьютере раметить флешку?
0
разметить
0
Покажите вывод
mount
0
root@OpenWrt:~# mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime,size=14580k)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,relatime,lowerdir=/,upperdir=/overlay)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
none on /proc/bus/usb type usbfs (rw,relatime)
0
Не пробовали флешку размечать на компьютере?
0
УРАААА ПОЛУЧИЛОСЬ!!!
0
Еще одна проблема что значит ?)


root@OpenWrt:~# tar -C /overlay -cvf - . | tar -C /mnt/usb -xvf -
./
./etc/
./etc/hotplug.d/
./etc/hotplug.d/block/
./etc/hotplug.d/block/40-mount
./etc/hotplug.d/block/10-swap
./etc/hotplug.d/block/20-fsck
./etc/e2fsck.conf
./etc/shadow-
./etc/uci-defaults/
./etc/uci-defaults/leds
./etc/uci-defaults/uboot-envtools
./etc/uci-defaults/wrt160nl
./etc/uci-defaults/vlan-migration
./etc/uci-defaults/network
./etc/uci-defaults/inittab-console-fixup
./etc/uci-defaults/migrate-shadow
./etc/uci-defaults/migrate-sysctl
./etc/dropbear/
./etc/dropbear/dropbear_dss_host_key
./etc/dropbear/dropbear_rsa_host_key
./etc/modules-boot.d/
./etc/modules-boot.d/30-fs-ext4
./etc/modules-boot.d/20-scsi-core
./etc/modules-boot.d/50-usb-uhci
./etc/modules-boot.d/60-usb-storage
./etc/modules-boot.d/40-scsi-core
./etc/modules-boot.d/20-lib-crc16
./etc/inittab
./etc/opkg.conf
./etc/config/
./etc/config/dhcp
./etc/config/fstab
./etc/config/firewall
./etc/config/dropbear
./
./etc/
./etc/hotplug.d/
./etc/hotplug.d/block/
./etc/hotplug.d/block/40-mount
./etc/config/ubootenv
./etc/config/network
./etc/config/system
./etc/config/wireless
./etc/ethers
./etc/init.d/
./etc/init.d/fstab
./etc/passwd
./etc/modules.d/
./etc/modules.d/30-fs-ext4tar: can't open './etc/hotplug.d/block/40-mount': File exists
0
Опять ошибка!!! Форматировал флешку через Acronis потом Invalid argument исчез при копировании пишет
input/output error
ошибка ввода/вывода Что делать?
0
А у Вас прошивка стоит из статьи?
0
Я не менял прошивку, как думаете может это из за прошивки? Может прошивку заново пере залить?
0
Кажется надо покупать новый роутер
0
В каком смысле не меняли прошивку, какая стоит конкретно?
Роутер убить достаточно трудно.
0
Я летом забыл ip для роутера, тогда я восстановил через терминал но там была openwrt прошивка где я скачал и сделал
0
Чем яснее вы будете писать, тем быстрее мы всё починим.
0
Роутер у вас TL-MR3020?
0
Здравствуйте! Я сегодня купил новый роутер
TL-MR3020
прошил по инструкций, все сделал как написано но когда пишу
mount -t ext4 /dev/sda1 /mnt/usb -o rw,sync
опять этот
Invalid argument
выходит.
Помогите пожалуйста я уже устал от этого ((((
Кстати у меня флешка Micro SD 1 Gb подключен к роутеру через USB адаптер, до этого было обычный Kingston 8 Gb, как думаете может вся эта вязня из за флешки?
Еще есть обычная флешка, тоже на 1 gb но она от компаний Transced.
Спасибо!
0
Используйте Transced
0
Или кингстон, не SD.
0
Добрый день, при попытке пинга и обновления репозитория пишет вот такое вот:

root@OpenWrt:~# ping ya.ru
ping: bad address 'ya.ru'
root@OpenWrt:~# opkg update
Downloading istarik.ru/packages/mr3020/packages//Packages.gz.
wget: bad address 'istarik.ru'
Collected errors:
* opkg_download: Failed to download istarik.ru/packages/mr3020/packages//Packages.gz, wget returned 1.
root@OpenWrt:~#

Файл конфигурации:

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.25'
option dns '8.8.8.8'
option gateway '192.168.1.1'

Что я не так делаю? Единственое что у меня не так как в статье, я использую точку доступа как клиент, подключенную к роутеру и уже к точке доступа по лан цепляю tplink, компьютер подключаю по вай фай к tplink, интернет на компе есть, на openwrt захожу без проблем, и пинг если цифрами ip задавать идет.
0
Хм, может Ваш провайдер блочит гугловские dns (8.8.8.8) Попробуйте вот эти 208.67.222.222, 208.67.220.220
option dns '208.67.222.222'
0
Вот ещё…

Списки публичных DNS серверов от Googla
Предпочитаемый DNS сервер — 8.8.8.8
Альтернативный DNS сервер — 8.8.4.4

Списки публичных DNS серверов Yandex

IP DNS базовый — 77.88.8.8
IP DNS безопасный — 77.88.8.88
IP DNS семейный — 77.88.8.7

Списки публичных DNS серверов от Level 3

IP DNS — 4.2.2.4
IP DNS — 4.2.2.2

Списки публичных DNS серверов от openDNS
IP DNS — 208.67.222.222
IP DNS — 208.67.220.220

Ну самый быстрый это свой собственный DNS сервер, который берет от корневых DNS.

Примечание о DNS:
-для дома можно смело прописывать первый два бесплатных ip dns от Гугла.
-для центрального офиса конечно несколько доменных DNS серверов, а вот для удаленных офисов можно добавить дополнительно парочку альтернативных DNS, что если упадет канал с офисом, можно было подключится по teamviewer ведь без DNS он не работает.
— публичные DNS российский от SkyDNS 193.58.251.251
— публичные DNS от Symantec 198.153.192.1
— публичные DNS от UltraDNS 156.154.70.1
— публичные DNS от Cisco 64.102.255.44 28.107.241.185

Ну, или днс провайдера укажите.
0
Попробовал все, пинга нет, грешу на мое подключение, что через клиент, а не напрямую в роутер. Подскажите, если ли возможность загрузить все необходимое на компьютер и потом уже с компьютера перенести на tplink?
0
Опишите, что, куда и как подключено, а то не совсем понятно.

DNS провайдера пробовали указать?
0
Есть роутер (192.168.1.1), в него по wan входит интернет и он раздает wifi сеть и dhcp, к нему я подключаюсь с помощью точки доступа, которая работает как клиент (192.168.1.2), dhcp отключен, у точки доступа 2 порта (wan и lan, она может работать как роутер), в lan порт подключен tp link openwrt (192.168.1.25). Компьютер подключен по wifi к tp link openwrt. Захожу на tp link openwrt без проблем по wifi.
DNS указывал все из списка выше.
0
Попробуйте так option dns '192.168.1.1'

Или днс провайдера укажите.
0
Выполнил
Ждём 5 минут… Не трогайте и не отключайте роутер!
После этого в браузере router не доступен ни по 192.168.0.254, ни по 192.168.0.1
По телнету не соединяетя, по ssh запрашивает пароль но его не принимает
комментарий был удален
0
По ssh 192.168.1.1 не принимает пароль
0
telnet 192.168.1.1
0
при попытке переноса на флешку пишет ошибку
root@OpenWrt:~# opkg install kmod-usb-core kmod-usb-storage kmod-fs-ext4 kmod-sc
si-core block-mount e2fsprogs fdisk kmod-usb-uhci kmod-usb-ohci
Package kmod-usb-core (3.3.8-1) installed in root is up to date.
Package kmod-usb-storage (3.3.8-1) installed in root is up to date.
Package kmod-fs-ext4 (3.3.8-1) installed in root is up to date.
Package kmod-scsi-core (3.3.8-1) installed in root is up to date.
Package block-mount (0.2.0-9) installed in root is up to date.
Installing e2fsprogs (1.42.4-1) to root…
Downloading istarik.ru/packages/mr3020/packages//e2fsprogs_1.42.4-1_ar71x x.ipk.
Installing libext2fs (1.42.4-1) to root…
Downloading istarik.ru/packages/mr3020/packages//libext2fs_1.42.4-1_ar71x x.ipk.
Installing libcom_err (1.42.4-1) to root…
Downloading istarik.ru/packages/mr3020/packages//libcom_err_1.42.4-1_ar71 xx.ipk.
Installing fdisk (2.21.2-1) to root…
Package kmod-usb-uhci (3.3.8-1) installed in root is up to date.
Package kmod-usb-ohci (3.3.8-1) installed in root is up to date.
Configuring libcom_err.
Configuring libext2fs.
Collected errors:
* extract_archive: Cannot create symlink from ./usr/sbin/mkfs.ext3 to 'mke2fs': No space left on device.
* extract_archive: Cannot create symlink from ./usr/sbin/mkfs.ext4 to 'mke2fs': No space left on device.
* wfopen: /usr/lib/libe2p.so.2.3: No space left on device.
* extract_archive: Cannot create symlink from ./usr/lib/libe2p.so.2 to 'libe2p. so.2.3': No space left on device.
* wfopen: /etc/e2fsck.conf: No space left on device.
* pkg_write_filelist: Failed to open //usr/lib/opkg/info/e2fsprogs.list: No spa ce left on device.
* opkg_install_pkg: Failed to extract data files for e2fsprogs. Package debris may remain!
* opkg_install_cmd: Cannot install package e2fsprogs.
* verify_pkg_installable: Only have 16kb available on filesystem /overlay, pkg fdisk needs 47
* opkg_install_cmd: Cannot install package fdisk.
* opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: N o space left on device.

что делать и как решить?
0
а когда вставил флешку не определяет и пишет
root@OpenWrt:~# fdisk -l
-ash: fdisk: not found
0
Какая у Вас прошивка стоит?
0
прошивка вот эта openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
отсюда sourceforge.net/projects/orwrt/files/0.77/
0
предлагаете попробовать залить ИМЕННО вашу прошивку сверху статьи??
0
Система Вам написала, что часть программ уже установленна:
Package kmod-usb-core (3.3.8-1) installed in root is up to date.
Package kmod-usb-storage (3.3.8-1) installed in root is up to date.
Package kmod-fs-ext4 (3.3.8-1) installed in root is up to date.
Package kmod-scsi-core (3.3.8-1) installed in root is up to date.
Package block-mount (0.2.0-9) installed in root is up to date.
...


После попытки установить другие проги выяснилось что не хватает места…
No space left on device.

Придётся ставить прошивку заново.
0
это я понял. но не хватает места походу именно на нужную fdisk. а прямо на мою установленную прошивку можно будет залить указанную Вами наверху прошивку?
0
Нет, только устанавливать заново.

А почему Вы ставите программы из моего репозитория, у Вас же другая прошивка?
0
оооо а репозитарий и прошивка должны совпадать??? устанавливать как вы описали сверху?
я просто не пойму почему не работают кнопки с веб сервера ведь когда посылаю команду
root@OpenWrt:~# ls /dev/tty*
/dev/tty /dev/ttyATH0 /dev/ttyS0
ответ приходит! значит юарт подключен?!
0
а хотя нет!!! почему то ответ от роутера в виде
/dev/tty /dev/ttyATH0 /dev/ttyS0 приходит даже после отключения пинов юарт от ардуино!!!
ничего не пойму!
0
Программа ls ничего, никуда не посылает.
0
как не посылает? здесь
Вы сами писали ее писать чтобы показать устройства.
0
Она и показывает наличие устройства, но ничего в него не пишет и не читает.
0
прошил сейчас вашу прошивку. а веб сервер остался таким же каким был…
0
Либо не прошили либо это кеш браузера.
0
все сделал заново. уф. дошел до конца почти.
root@OpenWrt:~# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 1.3M 1.2M 164.0K 88% /
/dev/root 1.5M 1.5M 0 100% /rom
tmpfs 14.2M 80.0K 14.2M 1% /tmp
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mtdblock3 14.8G 353.7M 13.7G 2% /overlay
overlayfs:/overlay 1.3M 1.2M 164.0K 88% /
/dev/sda1 14.8G 353.7M 13.7G 2% /overlay
root@OpenWrt:~# opkg update
Downloading istarik.ru/packages/mr3020/packages//Packages.gz.
Inflating istarik.ru/packages/mr3020/packages//Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
root@OpenWrt:~# opkg install kmod-nls-cp1251 kmod-nls-koi8r kmod-nls-utf8 kmod-n
ls-cp866 kmod-nls-cp437
Installing kmod-nls-cp1251 (3.3.8-1) to root…
Downloading istarik.ru/packages/mr3020/packages//kmod-nls-cp1251_3.3.8-1_ ar71xx.ipk.
Installing kmod-nls-koi8r (3.3.8-1) to root…
Downloading istarik.ru/packages/mr3020/packages//kmod-nls-koi8r_3.3.8-1_a r71xx.ipk.
Installing kmod-nls-utf8 (3.3.8-1) to root…
Downloading istarik.ru/packages/mr3020/packages//kmod-nls-utf8_3.3.8-1_ar 71xx.ipk.
Installing kmod-nls-cp866 (3.3.8-1) to root…
Downloading istarik.ru/packages/mr3020/packages//kmod-nls-cp866_3.3.8-1_a r71xx.ipk.
Installing kmod-nls-cp437 (3.3.8-1) to root…
Downloading istarik.ru/packages/mr3020/packages//kmod-nls-cp437_3.3.8-1_a r71xx.ipk.
Configuring kmod-nls-cp1251.
Configuring kmod-nls-utf8.
Configuring kmod-nls-cp437.
Configuring kmod-nls-cp866.
Configuring kmod-nls-koi8r.
root@OpenWrt:~# opkg install mc
Installing mc (4.7.5.3-2) to root…
Downloading istarik.ru/packages/mr3020/packages//mc_4.7.5.3-2_ar71xx.ipk.
Installing glib2 (2.26.1-3) to root…
Downloading istarik.ru/packages/mr3020/packages//glib2_2.26.1-3_ar71xx.ip k.
Collected errors:
* wfopen: /usr/lib/libgobject-2.0.so.0.2600.1: No space left on device.
* extract_archive: Cannot create symlink from ./usr/lib/libgmodule-2.0.so.0 to 'libgmodule-2.0.so.0.2600.1': No space left on device.
* extract_archive: Cannot create symlink from ./usr/lib/libgobject-2.0.so to 'l ibgobject-2.0.so.0.2600.1': No space left on device.
* extract_archive: Cannot create symlink from ./usr/lib/libglib-2.0.so to 'libg lib-2.0.so.0.2600.1': No space left on device.
* wfopen: /usr/lib/libgio-2.0.so.0.2600.1: No space left on device.
* extract_archive: Cannot create symlink from ./usr/lib/libgio-2.0.so.0 to 'lib gio-2.0.so.0.2600.1': No space left on device.
* extract_archive: Cannot create symlink from ./usr/lib/libgio-2.0.so to 'libgi o-2.0.so.0.2600.1': No space left on device.
* extract_archive: Cannot create symlink from ./usr/lib/libgthread-2.0.so to 'l ibgthread-2.0.so.0.2600.1': No space left on device.
* pkg_write_filelist: Failed to open //usr/lib/opkg/info/glib2.list: No space l eft on device.
* opkg_install_pkg: Failed to extract data files for glib2. Package debris may remain!
* opkg_install_cmd: Cannot install package mc.
* opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: N o space left on device.
root@OpenWrt:~# root@OpenWrt:~# df -h
-ash: root@OpenWrt:~#: not found
root@OpenWrt:~# Filesystem Size Used Available Use% Mounted on
-ash: Filesystem: not found
root@OpenWrt:~# rootfs 1.3M 1.2M 164.0K 88% /
-ash: rootfs: not found
все сделал точно. флешка даже как видите определилась. но опять не установились программы. пишет мало места. как так?
Скажите пожалуйста!
0
даже ЛЮСИ не установился нет места! наверно в месте где вы написали Ну вот, теперь места у нас полно, можно ставить что угодно.
надо сначала как то перейти на флешку в консоли, только потом устанавливать программы разве нет?
А так он все на внутр флешку походу поставил!
объясните пожалуйста! не ругайтесь ибо я новичок, но стараюсь разобраться!
0
Флешка у Вас определилась, но система на неё не перенеслась. Вам об этом сообщили:

Filesystem    Size    Used    Available    Use%    Mounted on
rootfs        1.3M    1.2M    164.0K        88%     /


Что-то Вы сделали не так или не доделали.

Покажите /etc/config/fstab

Статья расчитана на самых «маленьких», если слепо следовать инструкциям, то всё должно получится.
0
доброго дня, поставил, все работает, спасибо.
не подскажите как искать и где посмотреть, что бы добавить на установленное Asterisk и chan-dongle для работы со свистками.
0
Здравствуйте. Доступные пакеты можно посмотреть здесь...
0
Спасибо, а не подскажите в каком из пакетов есть (и есть ли) утилиты компиляции aclocal, autoconf, automake, make?
0
Пожалуйста.

Кросс-компиляция.
0
После установки вашей прошивки, рутер сдох, через UART не восстанавливается. Может знаете что делать? При подключении к терминалу просто бегут какие то символы и всё, все параметры выставлены правильно.
0
А какие символы бегут?
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.