WiFi Pineapple - TP-LINK TL-MR3020



Аппаратный снифер WiFi Pineapple на базе роутера TL-MR3020.



WiFi Pineapple — это устройство для аудита беспроводных сетей.

Своё название получило из-за того, что одно из первых устройств было замаскировано под ананас



Все действия производятся на Ubuntu.


Перво-наперво нужно установить на роутер прошивку OpenWrt, весь этот процесс я подробно описал вот здесь, там же ссылка на прошивку. Сделать нужно всё до четвёртого шага, до переноса системы на флешку.



Перенос системы


Берём флешку побольше (предполагается хранение на ней словарей) и на «большом компьютере» создаём на ней два раздела:

1. swap — приблизительно 200 мегабайт. Своп будет в начале.
2. ext4 — всё остальное.



Вставляем флешку в роутер и командуем:

opkg update
opkg install kmod-usb-storage kmod-fs-ext4 block-mount fdisk



Проверим флешку:

fdisk -l



Должно быть как-то так:


У меня флешка 8Гб.



Содаём папку /mnt/sda2, монтируем туда флешку и переносим систему:

mkdir -p /mnt/sda2
mount /dev/sda2 /mnt/sda2
mkdir -p /tmp/cproot
mount --bind / /tmp/cproot
tar -C /tmp/cproot -cvf - . | tar -C /mnt/sda2 -xf -
umount /tmp/cproot
umount /mnt/sda2



Редактируем /etc/config/fstab:

vi /etc/config/fstab

Два последних блока измените вот так:

config mount
        option target /
        option device /dev/sda2
        option fstype ext4
        option options rw,sync
        option enabled 1
        option enabled_fsck 0

config swap
        option device /dev/sda1
        option enabled 1

подсказка vi
Нажимаем символ "i".
Вносим изменения.
Нажимаем Esc.
Вводим последовательно символы :wq (: w-сохранить q-выйти)
Нажимаем Enter.
Файл отредактирован.



Перезагрузите роутер:

reboot





Проверим свободное место:

df -h



Система перенесена.


Установите (если хотите) web-интерфейс luci. После установки Pineapple, luci будет работать не полностью.

opkg update
opkg install luci luci-i18n-russian luci-proto-3g luci-proto-ppp ppp-mod-pptp ppp-mod-pppoa


Добавляем luci в автозагрузку и стартуем:

/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start



Можно переходить к следующему этапу...




Отключаем роутер, вынимаем флешку и вставляем её в компьютер.

Создаём в домашнем каталоге папку mr3020

mkdir /home/dima/mr3020


Копируем содержимое флешки в созданную папку:

Здесь и далее замените имя пользователя и флешки на свои.

sudo cp -R /media/dima/48278997-7272-422c-b706-2380797b8974/* /home/dima/mr3020/
sudo cp -R /home/dima/mr3020/lib /home/dima/mr3020/lib-original




Скачайте архив (это образ прошивки Pineapple) и распакуйте (обычным архиватором) в домашнюю папку.
Должно получится так — /home/dima/squashfs-root/

Образ взят отсюда (версия 2.8.1), если там есть версия посвежее, то скачайте и распакуйте её
командой
unsquashfs upgrade-2.8.1.bin


Предварительно установив squashfs-tools:

sudo apt-get install squashfs-tools




Переходим в папку…

cd /home/dima/squashfs-root


… и копируем Pineapple на флешку:

sudo cp -R bin/* /media/dima/48278997-7272-422c-b706-2380797b8974/bin/
sudo cp -R sbin/* /media/dima/48278997-7272-422c-b706-2380797b8974/sbin/
sudo cp -R usr/* /media/dima/48278997-7272-422c-b706-2380797b8974/usr/
sudo cp -R etc/* /media/dima/48278997-7272-422c-b706-2380797b8974/etc/
sudo cp -R www/* /media/dima/48278997-7272-422c-b706-2380797b8974/www/
sudo cp -R pineapple /media/dima/48278997-7272-422c-b706-2380797b8974/
sudo cp -R lib/firmware/* /media/dima/48278997-7272-422c-b706-2380797b8974/lib/firmware/
sudo cp lib/* /media/dima/48278997-7272-422c-b706-2380797b8974/lib/
sudo cp lib/wifi/* /media/dima/48278997-7272-422c-b706-2380797b8974/lib/wifi/





Теперь копируем на флешку некоторые файлы из папки mr3020

sudo cp /home/dima/mr3020/etc/config/fstab /media/dima/48278997-7272-422c-b706-2380797b8974/etc/config/
sudo cp /home/dima/mr3020/etc/passwd /media/dima/48278997-7272-422c-b706-2380797b8974/etc/
sudo cp /home/dima/mr3020/etc/shadow /media/dima/48278997-7272-422c-b706-2380797b8974/etc/
sudo cp -R /home/dima/mr3020/lib-original /media/dima/48278997-7272-422c-b706-2380797b8974/



Редактируем файлы на флешке:

/etc/config/networkв соответствии с вашей сетью.

...
config interface lan
	option ifname	eth0
	option type 	bridge
	option proto	static
	option ipaddr	172.16.42.1 # Поменяйте адрес
	option netmask	255.255.255.0
	option gateway  172.16.42.42 # Поменяйте шлюз
	option dns	8.8.8.8
...


/etc/config/wireless

config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  a0:f3:c1:31:ff:79
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-20
        list ht_capab   SHORT-GI-40
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40


config wifi-iface
        option device   radio0
        option network  lan
        option mode ap
        option ssid 'pineapple' # Название точки 
        option encryption 'psk2'
        option key '12345678' # Пароль 


/etc/opkg.confменяем первую строчку.

src/gz attitude_adjustment http://istarik.ru/packages/mr3020/packages/
#src/gz pineapple_packages http://cloud.wifipineapple.com/packages
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
dest usb /usb


Если устанавливали luci, тогда в файле /etc/config/uhttpd (это конфиг сервера) надо поменять строчку:

option 'index_page' 'index.php'


на

option 'index_page' 'index.html'



Возвращаем флешку в роутер, включаем, заходим и видим…
(ssh сообщит о неизвестном хосте)



Если всё прошло удачно, то пользователь будет Pineapple, если это не так, то «что-то пошло не так». Возвращайтесь в начало и ищите где допустили ошибку.



Открываем браузер по адресу ip-адрес:1471 (логин — root, пароль — пароль для ssh) и любуемся…




Зайдите в раздел USB, отредактируйте fstab в соответствии с рисунком и нажмите Update fstab.




Раздел Pineapple Bar не работает, поэтому пакеты устанавливаются стандартным способом, с помощью opkg install

opkg install пакет


Посмотреть доступные пакеты opkg list или opkg list | more

opkg update
opkg list | more


Или здесь.


По желанию доустановите различные программы:

opkg update
opkg install mc nano tcpdump curl wget kismet-drone kismet-client kismet-server netcat nmap reaver



Дополнительно можно установить bully и pixiewps (в репозитории их нет).

opkg update
cd /tmp
wget //istarik.ru/file/bully.ipk
wget //istarik.ru/file/pixiewps.ipk
opkg install /tmp/bully.ipk
opkg install /tmp/pixiewps.ipk



Установка OpenVPN описана вот здесь.



Не могу поручиться за стопроцентную работоспособность, так как весь функционал не проверял. На этом всё...


  • 0
  • 6101

Комментарии (4)

0
config wifi-device radio0
option type mac80211
option channel 11
option macaddr 60:e3:27:81:2e:ac
option hwmode 11ng
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid 'pneapple'
option encryption 'psk2'
option 'test12345'
0
не могу решить проблему с Wi-Fi, не заводится(
0
А что говорит ifconfig, и заодно покажите /etc/config/network
0
Он и не запустится последняя строка
option 'test12345'
Должна выглядеть так:
option key 'test12345'
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.